Building a Lifted EZGO Shuttle 6. Need Help With 35 HP Briggs Install

Discussion in 'Lifted Golf Carts' started by roccoga, Oct 30, 2017.

  1. roccoga

    roccoga Member

    maybe the belt might be to tight?
     
  2. roccoga

    roccoga Member

    i adjusted belt to 1 1/2 downward movement
     
  3. pbillyi69

    pbillyi69 Well-Known Member

    yes im sure you need one with a stronger spring. dont know which one i think they are color coded im pretty sure my was yellow. i put an 18hp with rev kit but could be talkin straight out my butt. Rod, Nubs, or DS will know for sure
     
  4. roccoga

    roccoga Member

    thanks for the help.
     
  5. pbillyi69

    pbillyi69 Well-Known Member

    thats about right for the belt.....im sure you need a different driven clutch i just dont know which one. did you change any adjusment on the shift linkage?
     
  6. roccoga

    roccoga Member

    this is where i am glad this forum is here. i had shift linkage of when rebuilding cart. maybe it needs adjustments? i will have to check tomorrow
     
  7. HotRodCarts

    HotRodCarts Cartaholic

    You can try turning the idle down if you haven't already.

    The cart looks good, you did a nice job on it.
     
  8. roccoga

    roccoga Member

    I turned the idle down today.it helped a little still has a hard time switching from forward to reverse unless i play with the go pedal. i think the governor is messing with me top speed was 23. it only goes that speed if i start from a complete stop if not it is a slug maybe 10 mph. the linkage on top of the rear axle i removed when i put engine in is this something that is needed? The linkage that was hooked to factory governor? how do i check the driven clutch to see if i need the stronger spring? thanks for all the help. i sure makes me feel good knowing it drives.just have to work out a few things. oh ya header wrap is definitely needed.i only burned myself 1 hundred times adjusting things today:mad:
     
  9. Nubs

    Nubs Cartaholic

    The linkage on top of the diff is just the road speed governor and not needed. is the drive clutch trying to engage at idle? maybe there is not enough slack in the belt, inside of belt could be rubbing on the bottom of the drive clutch? it will perform much better with the engine governor out of the mix.

    I would be running a tach so you know just whats going on and when:twocents:
     
  10. roccoga

    roccoga Member

    Thanks for help and yes sometimes drive clutch was trying to engage now not so much it only when rpm is taking a while to come down. I would like to trash the governor so a tach will be in the future. Is there a linkage i could get that does away with this crazy set up?
     
  11. Nubs

    Nubs Cartaholic

    Need to make up your own deal, I would try and live with it and get yourself a ATV style carb and 99% of those problems will go away:twocents:

    That drive clutch is it? May need a different spring
     
  12. roccoga

    roccoga Member

    the drive clutch is comet 1190.
     

    Attached Files:

  13. roccoga

    roccoga Member

    i have this 38 off the green monster
     
  14. Nubs

    Nubs Cartaholic

    That would work, make a adapter or buy one. May have to fatten up the idle circuit, reading the plugs will help dail er in.
     
  15. Nubs

    Nubs Cartaholic

  16. roccoga

    roccoga Member

    i haven't done much to it. i have been building a barn for the wife. but is a good tool hauler and lake breaker!!! I still have to figure out carb situation, it would be nice to get some more speed out of her:yes:
     

    Attached Files:

  17. HotRodCarts

    HotRodCarts Cartaholic

    Nice pictures. Thanks for posting them. :thumbsup:
     
  18. roccoga

    roccoga Member

    Thanks Cartaholics for being here and helping with my build. Top notch group.
     
    HotRodCarts likes this.
  19. Nubs

    Nubs Cartaholic

    Nice, they make different gear ratios.
     

Share This Page