EZGO TXT rear axle problem

Discussion in 'EZGO Electric' started by Volker, Jul 9, 2018.

  1. Volker

    Volker New Member

    Hi guys,
    I'm new here and I need some help about the rear axle on a 2003 ezgo txt electric golf cart.
    The cart want go forward or reverse but the motor is running.
    I took the wheels and the hubs of the cart and run the cart. Both shafts are spinning.
    If I hold one shaft with my hands and run the cart I still can hold the shaft. Left or right it doesn't matter
    Is this normal ?
     
  2. HotRodCarts

    HotRodCarts Cartaholic

    If the motor is spinning but the cart isn't moving you probably have stripped splines in one of the hubs/brake drums. It's normal to be able to hold one axle and the other still spins on a open rear end.
    Welcome to the forum. :hattip:
     
  3. Volker

    Volker New Member

    Thx for the quick response.
    That's great news for me because of. One spline is stripped on on hub but the shaft spline is ok.
    Still I don't understand why you can grab the shaft when it's under load and you can hold it?
    I'm a mechanic and I cant hold a shaft under load on a car !
    Thx again for the quick response.
     
  4. HotRodCarts

    HotRodCarts Cartaholic

    It's a little harder to hold one on a car but if it has a open rear either side can be held while the other side is spinning.
     
  5. Volker

    Volker New Member

    Thx again for the quick response
    New hub is on order. I hope that's it.
    I keep you updated when I put everything together.
    Thx again
     
  6. Volker

    Volker New Member

    Buy the way. I got this from Dana. Its a great diagram from the rear axle on a Ezgo TXT
     

    Attached Files:

  7. HotRodCarts

    HotRodCarts Cartaholic

    Thanks for the diagram. Take a look through the resource section of the forum there's a lot of diagrams and service manuals in there. When you replace the hubs tighten the nuts to 100 ft lbs then tighten more if needed to align the cotter key.
     
  8. Volker

    Volker New Member

    Hi HotRodCart
    Thx for the info on the resource section.
     
    HotRodCarts likes this.
  9. HotRodCarts

    HotRodCarts Cartaholic

    No problem, you're welcome. :hattip:
     
  10. Volker

    Volker New Member

    Hi guys
    Finally I got my hub in. Easy swap. Plus I got new leave springs and bushings.
    Cart is up and running. Yeeeeeeha
    Thx for y'all help
     
  11. HotRodCarts

    HotRodCarts Cartaholic

    Glad to hear the new hub fixed the problem and thanks for the follow up.
     

Share This Page