Fuel Not Reaching Filter

Discussion in 'EZGO Gas 4 Stroke' started by mikerose, Jan 7, 2018.

  1. mikerose

    mikerose Member

    2014 EZGO gas golf cart with Kawasaki engine. The the hose to the crankcase has good impulse. The line to the carburetor has good pressure or feels like it does anyway. But no fuel is reaching the pump I think. I can't see any fuel in the filter which is right before the pump. Tank tube is not cracked. I cranked the engine and see no fuel filling the filter. Bad fuel pump? Any help is appreciated.
     
  2. Nubs

    Nubs Cartaholic

    I would pull the filter off and see if it pumps, I have never been a big fan of the filter before pump but that's the way they set them up :twocents:
     
  3. mikerose

    mikerose Member

    i pulled filter off and still no flow. ??? order a new pump?
     
  4. Nubs

    Nubs Cartaholic

    Well if we're sure there is no blocked inlet / pulser lines then I would say yes.
     
  5. mikerose

    mikerose Member

    will a weak battery be a cause to not pump enough fuel?
     
  6. Nubs

    Nubs Cartaholic

    If the engine spins it should pump, you did say that you could feel the pulser line working? can you blow air from the inlet line back to the tank?, Are you sure the pickup in the tank is good
     
  7. mikerose

    mikerose Member

    i took pump apart and put back. looks like i have fuel flowing now but still sputters a bit. battery is at 20% charge. thats why i asked if battery will affect performance.
     
  8. Nubs

    Nubs Cartaholic

    Well the faster the engine turns the more/better it pumps, give the battery a good charge and try it again.
     
  9. mikerose

    mikerose Member

    looks like it was the battery. gave it a good charge and is back to running normal. didnt realize the battery played that big a role.
     
  10. Nubs

    Nubs Cartaholic

    Glad to hear its up and running, thanks for posting the outcome:hattip:
     
  11. mikerose

    mikerose Member

    well bad news. not working again. how many spark plugs should the kawasaki engine have by the way. removed the top plug and it was wet. motor oil smelled like it had gas in it. please help
     
  12. Nubs

    Nubs Cartaholic

    Is the oil level over full on the dip stick? sounds like the fuel pump is bad and fuel is getting sucked into the crankcase.
     
  13. mikerose

    mikerose Member

    i put new fuel pump already. then this happend
     
  14. mikerose

    mikerose Member

    im thinking carb needs a good cleaning?????
     
  15. Nubs

    Nubs Cartaholic

    It would be the next step:twocents: if the float is sticking it will flood for sure.
     
  16. mikerose

    mikerose Member

    i appreciate the info. will get back to you.
     

Share This Page