HDK Onboard Battery Charger Not Charging Batteries

Discussion in 'Other Manufacturers Electric' started by sloar, Jun 10, 2018.

  1. sloar

    sloar New Member

    Hopefully someone here can help me. My batteries started dying last summer, they wouldn't charge. I recently picked up all new batteries and installed them. My kids rode the cart around for awhile and the readout said 50% on the charge. I plugged in the HDK onboard battery charger and it doesn't seem to be charging the batteries, 24 hours later no difference in charge. A solid red light on the charger panel which means charging error. Any thoughts or ideas to get me started in the right direction?
     
  2. HotRodCarts

    HotRodCarts Cartaholic

    What make and model is the battery charger? Are you sure you have the charger wired to the right batteries? What's your voltage reading at the battery charger receptacle on the golf cart?
    Welcome to the forum. :hattip:
     
  3. sloar

    sloar New Member

    thanks for the reply, I'm at work so I cant test anything until Tuesday morning. I was hoping someone had ran into this before. I do know that it has four wires coming from the plug, white and black connected my a sensor block hooked to the back battery negative post second from the driverside, a red wire hooked to the positive on the first back battery on the driverside and a green that is not hooked up and is not needed. The red is also hooked to the carts positive cable and the white and black is combined with the carts negative cable. Hope that helps a little because carts are not in my wheelhouse.
     
  4. HotRodCarts

    HotRodCarts Cartaholic

    I din't know much about HDK carts but I'd start with testing the battery pack voltage where the charger is wired to the batteries and make sure you have full pack voltage there.
     
  5. sloar

    sloar New Member

    I think I figured out the problem, when I try charging it I get an error code saying the batteries are to weak for the charger to take over. I tested each battery with a multimeter and get 8.4 on each. I read that each one needs to be around a 9. I’m trying to charge each battery individually, I can get them to a 9 but they slowly drop back down around 8.6 while I’m charging the next one. Any ideas on that?
     
  6. HotRodCarts

    HotRodCarts Cartaholic

    Are they 8 volt batteries? If they are their fully charged or close to it at that voltage.
     
  7. sloar

    sloar New Member

    Yes 8v batteries, but my onboard charger has an error code saying weak or batteries not connected. Everything is wired up and it drives fine.
     
  8. HotRodCarts

    HotRodCarts Cartaholic

    Sounds like there's a problem with the battery charger then.
     
  9. rob Francis

    rob Francis New Member

    Hi, I was getting the same red light light error and the error code was E02- battery voltage to high or to low. It started with me needing to unplug a few times for it to work and eventually I was plugging/unplugging for 2 hours before it would start to charge the batteries. I contacted a HDk dealer by phone who told me it sounded like a charger issue and probably would need s new one. I decided to take it to a club car dealer who sells HDk carts and he advised my that my Curtis controller was the issue and it would need to be replaced. I then made the decision to trade the cart in and purchase a club car petrol.
     
  10. HotRodCarts

    HotRodCarts Cartaholic

    Thanks for the info Rob and welcome to the forum. :hattip:
     

Share This Page