HDK Onboard Battery Charger Not Charging Batteries

Discussion in 'Other Manufacturers Electric' started by sloar, Jun 10, 2018.

  1. sloar

    sloar New Member

    Hopefully someone here can help me. My batteries started dying last summer, they wouldn't charge. I recently picked up all new batteries and installed them. My kids rode the cart around for awhile and the readout said 50% on the charge. I plugged in the HDK onboard battery charger and it doesn't seem to be charging the batteries, 24 hours later no difference in charge. A solid red light on the charger panel which means charging error. Any thoughts or ideas to get me started in the right direction?
     
  2. HotRodCarts

    HotRodCarts Cartaholic

    What make and model is the battery charger? Are you sure you have the charger wired to the right batteries? What's your voltage reading at the battery charger receptacle on the golf cart?
    Welcome to the forum. :hattip:
     
  3. sloar

    sloar New Member

    thanks for the reply, I'm at work so I cant test anything until Tuesday morning. I was hoping someone had ran into this before. I do know that it has four wires coming from the plug, white and black connected my a sensor block hooked to the back battery negative post second from the driverside, a red wire hooked to the positive on the first back battery on the driverside and a green that is not hooked up and is not needed. The red is also hooked to the carts positive cable and the white and black is combined with the carts negative cable. Hope that helps a little because carts are not in my wheelhouse.
     
  4. HotRodCarts

    HotRodCarts Cartaholic

    I din't know much about HDK carts but I'd start with testing the battery pack voltage where the charger wired to the batteries and make sure you have full pack voltage there.
     

Share This Page