Strange LED Directional issue

Discussion in 'EZGO Electric' started by Bilito, Aug 11, 2018.

  1. Bilito

    Bilito New Member

    I am installing my new Side View Mirrors with LED directional signals built in and something is wrong. I am using the T-Tap connectors tapping into the Directional wires. I unplugged the wire plug to the direction light that is part of the headlight and tapped into those wires, black to black etc, the lights in the mirror worked great, plugged the headlight directional back in and it all worked great, then 30 40 seconds later it all stopped working. If I turn the directional switch off and then right back on it works and then shuts off again, checked all the connections again and again. Can not be an overload, LEDS do not use much juice. could those t taps be an issue??
     
  2. Bilito

    Bilito New Member

    UPDATE...The issue appears to be with the original LED headlight, taillight, directional kit. I only connected the signal mirror to the right side so I decided to run the right signal and see long it would flash, sure enough it took about the same time and it shut off. Could there be timer built into the directional signals so you cannot leave them on ????
     
  3. Bilito

    Bilito New Member

    FURTHER UPDATE,, It appears that the directional are on a built in 30 second timer, no matter what side is on at exactly 30 seconds they shut off
     
  4. HotRodCarts

    HotRodCarts Cartaholic

    The timer would make sense so that's probably why they shut off after 30 seconds. Does the documentation that came with the lights say anything about a built in timer?
     
  5. Bilito

    Bilito New Member

    Yes 36 flash's either side and it shuts off
     
  6. Bilito

    Bilito New Member

    Nothing in the documentation even says how to use it. It is a GTW led light kit part number 32022.
     
  7. HotRodCarts

    HotRodCarts Cartaholic

    I found some instructions for a GTW LED light kit with turn signals and brake lights that shows a time delay in the wiring harness. Does your cart have brake lights also. If it does do they go off after 30 seconds if the parking brake is set with the brake lights on?
     
  8. Bilito

    Bilito New Member

    It has brake lights, turn signals and horn and after 35 flashes they turn off whether the brake is set or not
     
  9. HotRodCarts

    HotRodCarts Cartaholic

    Do the brake light turn off if left on?
     
  10. Bilito

    Bilito New Member

    Brake light comes on while setting brake but goes out the moment the brake is set
     
  11. HotRodCarts

    HotRodCarts Cartaholic

    From what I read in the install instructions I'd say the turn signal turning off after 30 seconds is normal. Although the instructions aren't clear about the timer relay.
     
  12. Bilito

    Bilito New Member

    I wonder if that timer is adjustable? 30 seconds just seems too short a time.
     
  13. HotRodCarts

    HotRodCarts Cartaholic

    It didn't show any adjustment in the documentation. It doesn't even state how long the default timer is set for. :dazed:
    Your best bet would be contact the manufacturer and ask them about it. :twocents:
     
  14. Nubs

    Nubs Cartaholic

    30 sec's seems good to me unless your dealing with traffic lights :twocents:
     
    HotRodCarts likes this.

Share This Page